Lambda delay settings for Innovate LC-2

Moderator: Tom Notch

Post Reply
paullanzarotti
Posts: 37
Joined: Sat Dec 13, 2014 4:01 pm

Lambda delay settings for Innovate LC-2

Post by paullanzarotti » Sun Jan 01, 2017 7:26 pm

I am having trouble getting VE Analyze in Tuner Studio t create a consistent table. Every drive it's changing cells that have already been altered which make me suspect that my Lambda delay settings are off.

The car is aMexican Beetle 1600i with single TB and standard Mexican set up. The ECU is MS2.

Can anyone tell me if these settings are correct?
You do not have the required permissions to view the files attached to this post.

User avatar
Chip Birks
Posts: 2477
Joined: Wed Mar 12, 2008 7:59 pm
Location: Pleasant Grove, Utah

Re: Lambda delay settings for Innovate LC-2

Post by Chip Birks » Sun Jan 01, 2017 7:58 pm

You are the only person who can determine if they are right. It's based on exhaust length and such.

You need to determine how long it takes for your sensor to see changes in your fueling. Easiest way I've heard is to basically set up a fuel cutting rev limiter at a spot on your map, run into that limiter at 3 different load points then measure how long it took from the time pw zero'd, until the time your o2 sensor shows full lean. Repeat that at 3 different rpm windows, and you should have enough info to fill out your table.

User avatar
gtmdriver
Posts: 104
Joined: Mon May 21, 2012 3:38 am

Re: Lambda delay settings for Innovate LC-2

Post by gtmdriver » Mon Jan 02, 2017 6:53 am

Basically it as done as Chip describes. You need to collect your own data.

You need to measure how long it takes the lambda sensor to detect changes in throttle position at 3 different rpm points and 3 different throttle openings making 9 readings in total and you need to do each of these a few times to get a representative average reading.

Post Reply