Windsheild Install Trouble

Need help straightening that dent? Or painting your car? This is the place to be!
Post Reply
User avatar
Big Ratfink
Posts: 44
Joined: Sun Oct 03, 2010 11:37 pm
Location: Menominee, Mi

Windsheild Install Trouble

Post by Big Ratfink » Sun May 28, 2017 8:44 am

My boy and I are getting our butts kicked trying to put a new windshield in his 74 bug, we're using a new WCM seal. We can get it 90% installed, but just can't seem to get the top inside seal to fully go over that strip of metal teeth that clamp the headliner to the steel lip. We have tried using silicon and dish soap for lube. This is the second window, I busted the first one trying to whack it in further.

Is that metal strip necessary? The factory got the window in but maybe the new window rubber won't fit over it? Any tricks?

User avatar
SCOTTRODS
Posts: 479
Joined: Sun Nov 07, 2010 10:15 am
Location: Garland, TX

Re: Windsheild Install Trouble

Post by SCOTTRODS » Sun May 28, 2017 10:10 am

The metal strip isn't 100% necessary. It was used, as you guessed, to hold the headliner in. As long as you aren't doing a new headliner, that wouldn't be necessary on a new windshield replacement. The headliner should be very well shaped and holding with no clips by now. I have done several and found the same issues as you over the years, and eventually stopped beating myself up trying to keep that clip in there.

I used to start the rubber at the top and that helped as well, but still made the bottom really difficult sometimes due to the strip holding things back a little. I also used smooth, small gauge Weed Eater string for my pull through string and that made things a huge breeze... it lubes along with the rubber pretty well and doesn't cut or tear the rubber in the tight spots.

Also, Warmer weather seems to help too... Warming the rubber for flexibility is an option, but it cools really fast.
I have found them completely missing more than once. - PILEDRIVER

Some pics of My Powder Coating work
http://s244.photobucket.com/albums/gg6/terrellster/
My Facebook Page for Powder Coating
http://www.facebook.com/profile.php?id=100001788886297

User avatar
Big Ratfink
Posts: 44
Joined: Sun Oct 03, 2010 11:37 pm
Location: Menominee, Mi

Re: Windsheild Install Trouble

Post by Big Ratfink » Sun May 28, 2017 10:45 am

Thanks.

We're not doing a headliner today, so I'll pull those metal strips and give it a shot. I'll bet that window just jumps in the hole now!

User avatar
Big Ratfink
Posts: 44
Joined: Sun Oct 03, 2010 11:37 pm
Location: Menominee, Mi

Re: Windsheild Install Trouble

Post by Big Ratfink » Sun May 28, 2017 11:28 am

Yup, it jumped right in! Took less than ten minutes after we pulled those strips.

User avatar
SCOTTRODS
Posts: 479
Joined: Sun Nov 07, 2010 10:15 am
Location: Garland, TX

Re: Windsheild Install Trouble

Post by SCOTTRODS » Thu Jun 01, 2017 10:24 am

Good to hear... Sometimes, ya just have to be smarter than the Car... LOL
I have found them completely missing more than once. - PILEDRIVER

Some pics of My Powder Coating work
http://s244.photobucket.com/albums/gg6/terrellster/
My Facebook Page for Powder Coating
http://www.facebook.com/profile.php?id=100001788886297

Post Reply