My latest ride

With Turbo and Super charging you can create massive horsepower with vw motors.

Moderator: seabeebuggy

User avatar
Chip Birks
Posts: 2436
Joined: Wed Mar 12, 2008 7:59 pm
Location: Pleasant Grove, Utah

Re: My latest ride

Post by Chip Birks » Wed Aug 30, 2017 7:08 am

Sounds like you are going to have a fun weekend! How heavy is the car?

madmike
Posts: 1112
Joined: Mon Jul 24, 2006 5:11 pm
Location: Atlanta,Michigan

Re: My latest ride

Post by madmike » Wed Aug 30, 2017 10:23 am

Hope so. It's 1800lbs. :lol: with me

madmike
Posts: 1112
Joined: Mon Jul 24, 2006 5:11 pm
Location: Atlanta,Michigan

Re: My latest ride

Post by madmike » Thu Aug 31, 2017 7:14 am

I haven't driven on the pavement ,,yet bet it lifts in all 4 gears :lol:
You do not have the required permissions to view the files attached to this post.

User avatar
Chip Birks
Posts: 2436
Joined: Wed Mar 12, 2008 7:59 pm
Location: Pleasant Grove, Utah

Re: My latest ride

Post by Chip Birks » Sat Sep 02, 2017 12:34 pm

I hope your event goes better that mine! I've got a bug with one transmission setting right now, and thats first gear. Fingers crossed it was just a hockey stick...

madmike
Posts: 1112
Joined: Mon Jul 24, 2006 5:11 pm
Location: Atlanta,Michigan

Re: My latest ride

Post by madmike » Sun Sep 03, 2017 5:34 am

Bummer Chip, what happened? I'm Racin @ noon today,,,,,

madmike
Posts: 1112
Joined: Mon Jul 24, 2006 5:11 pm
Location: Atlanta,Michigan

Re: My latest ride

Post by madmike » Mon Sep 04, 2017 6:31 am

Great day racin
lost twice :oops:
spankin a 426 Hemi cuda
71 awd turbo eclipse
and a few V8 Camaro's too :lol: even took My 'Crew Chief' Matt for a pass.. he's extra 150 lbs was enough to lose to a nice camaro :roll: ,,I looked over at the driver and he was clapping his hand's ' goin across the finish line ,, that kid was so happy to beat me,, I'm still laughing
and Chip,, Nothing broke ....
You do not have the required permissions to view the files attached to this post.

madmike
Posts: 1112
Joined: Mon Jul 24, 2006 5:11 pm
Location: Atlanta,Michigan

Re: My latest ride

Post by madmike » Mon Sep 04, 2017 6:38 am

more pic's ,I didn't run the wheelie bars no need with only 1.8 was my best 60 ft. :oops:
note: Guy's this is run on an 'Airport' landing strip , they did try some sort of 'traction stuff ' so it helped a bit,
I did 'Lift' a few inches especially with Matt in the bug :lol:
You do not have the required permissions to view the files attached to this post.

User avatar
rubenski
Posts: 514
Joined: Mon Jun 30, 2014 5:28 am

Re: My latest ride

Post by rubenski » Mon Sep 04, 2017 6:42 am

Cool!!
Better to be blown than to suck!

yellow_snocone
Posts: 76
Joined: Thu Apr 27, 2017 3:26 pm
Location: NW indiana

Re: My latest ride

Post by yellow_snocone » Mon Sep 04, 2017 7:40 am

Gotta let the little guy win every now and then haha

yellow_snocone
Posts: 76
Joined: Thu Apr 27, 2017 3:26 pm
Location: NW indiana

Re: My latest ride

Post by yellow_snocone » Mon Sep 04, 2017 7:40 am

Gotta let the little guy win every now and then haha

madmike
Posts: 1112
Joined: Mon Jul 24, 2006 5:11 pm
Location: Atlanta,Michigan

Re: My latest ride

Post by madmike » Mon Sep 04, 2017 8:50 am

"U Bet'cha" :lol: :lol: :lol:
In that first pic, look to the Right of me
that's a "Tesla' he ask me to race him a few time's for $10.00 :shock:
I told him 'Maybe later when your Battery runs down" :lol: :lol:
someone told me 'He's running 7's :roll: His battery never did run down ,,,,FYI: my best on a concrete track ( as seen by the 60' times :roll: )was an 8.044 @91.4 mph,, Old racer told me to 'Save this slip " our reaction time were exactly the same :lol:
You do not have the required permissions to view the files attached to this post.

User avatar
Chip Birks
Posts: 2436
Joined: Wed Mar 12, 2008 7:59 pm
Location: Pleasant Grove, Utah

Re: My latest ride

Post by Chip Birks » Mon Sep 04, 2017 9:04 am

Glad to hear the day went well! Pretty sure my damage is limited to the shift fork...i hope.

madmike
Posts: 1112
Joined: Mon Jul 24, 2006 5:11 pm
Location: Atlanta,Michigan

Re: My latest ride

Post by madmike » Mon Sep 04, 2017 9:06 am

Your not running the 3/4 brass one are u?

User avatar
Chip Birks
Posts: 2436
Joined: Wed Mar 12, 2008 7:59 pm
Location: Pleasant Grove, Utah

Re: My latest ride

Post by Chip Birks » Mon Sep 04, 2017 10:12 am

Sorry, meant hockey stick.

User avatar
Chip Birks
Posts: 2436
Joined: Wed Mar 12, 2008 7:59 pm
Location: Pleasant Grove, Utah

Re: My latest ride

Post by Chip Birks » Mon Sep 04, 2017 10:34 am

What rpm were you launching at? I had 2 step switch adjustment issues this weekend, and had 60ft times that were similar to those. Launching at 7500 causes pretty good spin i found. I typically launch at about 5500 with boost. Mine only gives me 1.6s traditionally, even on a prepped surface. Mine will give similar 60s at 6500 with no boost. Kinda fun trying to tune this stuff.

Post Reply