My latest ride

With Turbo and Super charging you can create massive horsepower with vw motors.

Moderator: seabeebuggy

Post Reply
madmike
Posts: 1161
Joined: Mon Jul 24, 2006 5:11 pm
Location: Atlanta,Michigan

My latest ride

Post by madmike » Wed Jun 17, 2015 7:08 am

76 bug I swapped for my Dragster,Slapped in the 1915 w/T04 ,40 weber DCOE and BTM to control timing,, so far so good,,need to install the bung for the MTX-L
You do not have the required permissions to view the files attached to this post.

User avatar
rubenski
Posts: 551
Joined: Mon Jun 30, 2014 5:28 am

Re: My latest ride

Post by rubenski » Wed Jun 17, 2015 1:09 pm

Looking good, any hp nm numbers?
Better to be blown than to suck!

madmike
Posts: 1161
Joined: Mon Jul 24, 2006 5:11 pm
Location: Atlanta,Michigan

Re: My latest ride

Post by madmike » Thu Jun 18, 2015 7:06 am

Thanks Rub,Sorry no 'dyno' near me up here :roll: and I'm going to take it easy until I get it 'in tune' :wink:
Runs pretty good now 8)
You do not have the required permissions to view the files attached to this post.

madmike
Posts: 1161
Joined: Mon Jul 24, 2006 5:11 pm
Location: Atlanta,Michigan

Re: My latest ride

Post by madmike » Thu Jun 18, 2015 7:39 am

FYI
Spec on motor
Welded CW crank
Lighted flywheel
Balanced stock Rods
Mahle 94's Forged
All rotating parts Balanced
Mystery turbo cam :roll: :?:
1:25 autocraft's
CB 044's 'Semi Hemi' ported/ Mad Racing
7:1 cr
Deep sump
30mm F.F pump
Mystery Header?
Roto-Master T04 A/R 60
Brad penn 30wt
MSD 6al BTM and Msd dist.

madmike
Posts: 1161
Joined: Mon Jul 24, 2006 5:11 pm
Location: Atlanta,Michigan

Re: My latest ride

Post by madmike » Tue Jul 07, 2015 7:48 am

slapped in some huge jet in the 40 DCOE
from cb updated kit mains:?: & airs
F7 e tubes
1/16" drilled acc.pump jets
250 or 300(I forget :oops: ) inlet an opened up too no screen
boost ref the reg :wink:
"Life begins @ 15lbs of Boost" 8) 8) 8)
A/R goes to 10.5 even 9 on boost 12.5 idle and cruising,,,/off idle :lol:
so I'm in the ballpark :lol:

Ol'fogasaurus
Posts: 13269
Joined: Tue Nov 14, 2006 1:17 am
Location: Just north of Seattle

Re: My latest ride

Post by Ol'fogasaurus » Tue Jul 07, 2015 10:02 am

PO'd Mike, pretty cool! Is it streetable or straight line only.

Lee

madmike
Posts: 1161
Joined: Mon Jul 24, 2006 5:11 pm
Location: Atlanta,Michigan

Re: My latest ride

Post by madmike » Mon Jul 13, 2015 7:37 am

Very streetable,, but no wipers,,yet or brake lights, but It's has carpet & a Headliner and a Passengers seat :lol: :lol: :lol:
so Drag only for now 8) finally drove on a paved road
,,Boost creep to 20+lbs ,, bang ,,blew an intake gasket(found intake leak :roll: )
all's well,, going to the Michigan 'Bug Run' this Sunday 8) 8) 8)
You do not have the required permissions to view the files attached to this post.

User avatar
rubenski
Posts: 551
Joined: Mon Jun 30, 2014 5:28 am

Re: My latest ride

Post by rubenski » Mon Jul 13, 2015 10:58 am

Haha, somethings gotta give!
Better to be blown than to suck!

madmike
Posts: 1161
Joined: Mon Jul 24, 2006 5:11 pm
Location: Atlanta,Michigan

Re: My latest ride

Post by madmike » Wed Jul 15, 2015 7:33 am

How very true, Better the one dollar gasket then a piston/head ect. :lol:
How many passes can a bone stock trans take :?: :lol: :lol: :lol:
I will see :roll: :lol: I did slap in a stock or HD Pressure plate and a sprung 4 puck
maybe I should put a sticker on the dash saying:E-A-S-Y on the hole shot!!! :lol: :lol:

User avatar
petew
Posts: 3259
Joined: Sat Oct 07, 2006 6:05 pm
Location: Sydney/Australia
Contact:

Re: My latest ride

Post by petew » Wed Jul 15, 2015 5:16 pm

Stock trans + 20psi of boost... hmm. We should run a book. I say, umm, 4 passes if you're gentle. ;)

madmike
Posts: 1161
Joined: Mon Jul 24, 2006 5:11 pm
Location: Atlanta,Michigan

Re: My latest ride

Post by madmike » Thu Jul 16, 2015 6:56 am

Bets? cool send $$ to Madmike's Racing fund :lol: :lol: :lol:
4 passes would be awesome :lol:
Last time I had a Bug at that strip i made one pass 8) , Then broke a cv :oops: :cry: 500miles trip for me just to break it :oops:
Boost will be turned down to 12-15lbs or so,,???????????? :lol: :lol: :lol:

madmike
Posts: 1161
Joined: Mon Jul 24, 2006 5:11 pm
Location: Atlanta,Michigan

Re: My latest ride

Post by madmike » Mon Jul 20, 2015 7:49 am

all bets in? :lol: I made 3 passes 8) No didn't Break :wink: but I wasn't impressed with only a 14.9@89mph/14.6 same speed (10lbs) with a simple turn of the knob (15lbs) 13.2@104mph ,,, i didn't want enter the race program with only the stock trans, an time trails were over ,thus only 3 passes :roll: ,I had of all things battery problems only 10 volts running my MSD system :oops: ,Everyone said it sounded good 8) and I did hammer on the poor trans on the last pass, 20lbs in the slicks helped save it :wink: so with more seat time I'm sure this little 1915cc would push it deep into the 12's or? but the 2276 is itch'in to run so 1st a better trans :lol: If the pic loads ?, i did beat the cool green bug bug,he missed 2nd :oops: his first run with a turbo too i sold him my old header last bug run,blown'thew 48 IDA's 8) :lol:
You do not have the required permissions to view the files attached to this post.

madmike
Posts: 1161
Joined: Mon Jul 24, 2006 5:11 pm
Location: Atlanta,Michigan

Re: My latest ride

Post by madmike » Tue Jul 21, 2015 6:54 am

My Crew Chief told me i did do 4 passes, :lol: , I was the first car down the strip that morning and printer was acting up to no slip :cry:
You do not have the required permissions to view the files attached to this post.

rs58rag
Posts: 48
Joined: Fri May 10, 2013 9:36 pm

Re: My latest ride

Post by rs58rag » Thu Jul 23, 2015 1:33 am

madmike.......very rich jets are holding back some performance.....You have to let's us know jet sizes.....I have every gage but no wideband yet. I have same size engine with 8:1, c45 cam, 1.1:1 rockers, 40x37 mofoco heads, EB40 rajay (EF70 compressor/B40 exhaust)....( used to run Garrett t3), .... 40 DCOE 2. I have 170 airs, 165/160 gas, .75/.78 pump jets... ... Had 65 f8 idles, .75 and .80 pump jets to remedy a lean pop when stabbing throttle, but too rich at idle. Needed less fuel at idle and more at progression phase. 40 dcoe-2 has 3 progression holes, I added a 4th (.75mm) progression hole that allowed use of .53 f9 idle with air/fuel mix at 2 turns out. ...I'll try 55 f9s and reset a/f mixture later. If your dcoe has 3 progression holes adding a 4th hole makes progression smoother without having to run huge idle jets. Tedious work but worth it..

madmike
Posts: 1161
Joined: Mon Jul 24, 2006 5:11 pm
Location: Atlanta,Michigan

Re: My latest ride

Post by madmike » Thu Jul 23, 2015 8:04 am

Thanks,58rag, mine is a DCOE 4 whatever that is? :lol:
has in it for now 165/155 mains,175 airs, F11/F7 e-tubes,60 F6 idles, I didn't look at the darn A/F gauge on that last pass :oops: ( I need to take my crewCheif for a ride :lol: )
I would rather have to fat then lean :mrgreen: , seriously Thinking about swapping the 1915 to 2276 :twisted: (It needs a nice over the Alt.Header so I can run a fan,, crackhead running the lights about cooked my heads last pass :evil: look he's smoking at the stating line :shock: :roll: :lol: )
then slap in 170/180 jets(Dave Kawell suggested),, never had an issue with popping when stabbing the throttle? but i did drill pump jet to 1/16" :lol:
I have no clue if it has the 3rd progressive holes?,maybe next time I have it off I'll remember to look :wink: :lol:

Post Reply