Grounding

Fuel Supply & Ignition Systems

Moderator: Tom Notch

Post Reply
UKLuke72
Posts: 142
Joined: Fri Nov 25, 2011 8:28 pm

Grounding

Post by UKLuke72 » Tue Nov 07, 2017 12:10 pm

Can someone please explain the difference between these two scenarios...

Relay board earthed to the engine.
All sensors earthed to the engine (same point)
Engine earthed to -ve terminal of the battery via gearbox earth strap.

Relay board earthed to an m6 stud.
All sensors earthed to the same point next to the relay board (m6 stud)
Stud earthed to -ve terminal of the battery direct with 1 wire.

Luke

User avatar
ps2375
Posts: 295
Joined: Mon Aug 18, 2014 10:04 am
Location: Meridian,ID

Re: Grounding

Post by ps2375 » Tue Nov 07, 2017 4:35 pm

Seems ground reference is the same in both. I would minimize resistance from stud to -ve terminal.

UKLuke72
Posts: 142
Joined: Fri Nov 25, 2011 8:28 pm

Re: Grounding

Post by UKLuke72 » Tue Nov 07, 2017 5:20 pm

The first one is how I've interpreted the Megamanual, the second one is how I wired mine up before I consulted the manual :D

Just wondering if I need to change what I have or not?

User avatar
ps2375
Posts: 295
Joined: Mon Aug 18, 2014 10:04 am
Location: Meridian,ID

Re: Grounding

Post by ps2375 » Tue Nov 07, 2017 6:05 pm

Good grounds are paramount to a well running system. If you are not experiencing any difficulties I wouldn't worry about it. The biggest thing you might see is an offset between AFR at controller display and MS. Or noise when logging. Otherwise stick with what you have.

UKLuke72
Posts: 142
Joined: Fri Nov 25, 2011 8:28 pm

Re: Grounding

Post by UKLuke72 » Tue Nov 07, 2017 6:07 pm

It doesn't work yet though... New installation.
I have the ground for the WBO2 running to the same m6 stud too FWIW

User avatar
ps2375
Posts: 295
Joined: Mon Aug 18, 2014 10:04 am
Location: Meridian,ID

Re: Grounding

Post by ps2375 » Wed Nov 08, 2017 6:01 pm

What WBO2? Does it have separate grounds for controller and the sensor heater? If so, ground the sensor away from the rest of the WB and MS grounds to reduce/eliminate noise problems.

UKLuke72
Posts: 142
Joined: Fri Nov 25, 2011 8:28 pm

Re: Grounding

Post by UKLuke72 » Thu Nov 09, 2017 3:16 am

MTX-L

User avatar
Chip Birks
Posts: 2458
Joined: Wed Mar 12, 2008 7:59 pm
Location: Pleasant Grove, Utah

Re: Grounding

Post by Chip Birks » Thu Nov 09, 2017 6:59 am

What version of MS are you running? Extra or B&G code? If Extra, remove the megamanual from your browsing history. In fact, block it with parental guide software. Only use the manuals found at msextra.com.

If using B&G code, upgrade to Extra :D

UKLuke72
Posts: 142
Joined: Fri Nov 25, 2011 8:28 pm

Re: Grounding

Post by UKLuke72 » Fri Nov 10, 2017 7:01 am

I believe I am on Extra and I have since bookmarked the relevant page :D

I have decided to get rid of the relay board, it doesn't cater for my needs really so I think I'll just make my own up.
Makes wiring to the DB37 much simpler too it would seem.

User avatar
Chip Birks
Posts: 2458
Joined: Wed Mar 12, 2008 7:59 pm
Location: Pleasant Grove, Utah

Re: Grounding

Post by Chip Birks » Fri Nov 10, 2017 9:50 am

I've done a few installs now, never used a relay board. I think it has value in pretty basic setups, but once you get busy, you need flexibility that it can't support.

UKLuke72
Posts: 142
Joined: Fri Nov 25, 2011 8:28 pm

Re: Grounding

Post by UKLuke72 » Fri Nov 10, 2017 11:59 am

Well for starters it doesn't have the facility to fire the coils... Kinda prerequisite lol. And seeing as I'm using IAC2B to fire the 2nd coil that'll have to come straight from the MS so already the harness I built is null.

User avatar
Dale M.
Posts: 1605
Joined: Mon Oct 05, 2009 10:09 am
Location: Just a Little Bit West Of Yosemite Valley

Re: Grounding

Post by Dale M. » Fri Nov 17, 2017 10:32 am

My concept when I was designing my system for a autocross car (incidentally it never happened) was to use aluminum plate (in package tray) to mount MS Computer and all relays and such (fuse blocks and whatever, ( relay board)) and bond plate to engine with large gauge wire maybe 8 or 6 gauge in that way all ground for CPU and relays and injectors where all grounded to a Common point...

Dale
Lives his life vicariously through his own self.
1970 "Kellison Sand Piper Roadster"

Ol'fogasaurus
Posts: 13205
Joined: Tue Nov 14, 2006 1:17 am
Location: Just north of Seattle

Re: Grounding

Post by Ol'fogasaurus » Fri Nov 17, 2017 3:02 pm

As metal gets older and more tired it's ability to transmit the ground starts to go down hill then, potentially/eventually fail. Add to that welding that isn't the best and spot welds and seams that can corrode the ground starts to go away. The same with positive earth/ground cars.

Add to that VWs used a braided ground strap that goes between the pan via the stud on the shock tower to the engine's starter and that kind of strap has a tendency to break down very quickly as the individual strands fail for one reason or another. Us old guys that have dealt with those "flat" ground cables and try to get rid of them as we find them; nasty things to say the least and should be replaced assuming you are going for a documented restoration, then they are necessary.

Dale's idea of a single mount in the rear of the car is probably in the right direction electricity wise... for a non-documented restoration that is. The VW's charging system is based in the rear (unless you are modifying for mid-engine or front engine) and because of voltage drop which requires going to a larger gauge wire (lower number) as the distance increases (http://www.rapidtables.com/calc/wire/wi ... -chart.htm http://www.calculator.net/voltage-drop-calculator.html http://www.cerrowire.com/files/file/voltagedrop.pdf) there is some advantage to basing in the rear of the car most of the time.; the same for a front engine car. Besides, the under dash access to a bug is bad.
Lee

My opinion is worth slightly less than what you paid for it.

jhoefer
Posts: 195
Joined: Wed Oct 05, 2011 4:30 pm

Re: Grounding

Post by jhoefer » Fri Nov 17, 2017 9:20 pm

ps2375 wrote:
Tue Nov 07, 2017 4:35 pm
Seems ground reference is the same in both. I would minimize resistance from stud to -ve terminal.
It's not. The reason you run ground wires for your sensors all the way back to the ECU is to avoid noise and voltage offset in your signals. If you ground your sensors to the engine block, the ground path for the sensor has to go through the same ground path (ground strap) as high current things like your charging system, ac, and fans and higher frequency noise sources like your coils and injectors.

The more current through a wire the higher the voltage across it is. So for an extreme example, if conditions meant a sensor was supposed to read 5 volts, but there was enough current through the ground strap to get 0.5 volts across it, the sensor would only read 4.5 volts because its "engine ground" is now 0.5 volts higher than the "chassis ground" the ECU is using. By running the sensor ground all the way to the ECU, it's unaffected and reads the true 5 volts.

Similar thing with the coils and injectors charging and discharging, it's going to create small ripples in the voltage along the ground path that can be picked up by the ECU. This is different than the EM interference that can be picked up if your sensor wires are unshielded, but the inaccurate sensor voltage effects are the same.

Post Reply