Urabus...it's in the works (Subaru EJ20T build)

Are you one of those confused people who can't make up their mind?
Post Reply
User avatar
panel
Posts: 3606
Joined: Sun Sep 24, 2000 2:01 am
Location: Victoria B.C. Canada
Contact:

Re: Urabus...it's in the works (Subaru EJ20T build)

Post by panel » Sun Jul 10, 2016 12:08 am

Hi guys , I'm having a weird idling/running problem on #1 cylinder. When I pull the #1 injector wire off it makes no difference in the idle. I can do this on all other cylinders and you can feel/hear the change in idle. I've swapped injectors with #2 and it runs the same so this eliminates a faulty injector I think. I've done an ohms test to check for a broken wire from a31/B134 and there is no break. I also pulled the spark plug lead and grabbed a spare plug to run it on the engine and you can see the spark jumping the gap so I assume this is happening in the head also.

I also just swapped over the CTS just in case and this seems to not make a difference with the black smoke at idle and while blipping the throttle. I'm assuming it's running this rich due to my lack of change from #1......maybe just straight fuel going out the exhaust.

My wiring I've been using in my conversion is this one--> http://www.northursalia.com/modificatio ... /link5.pdf

Any help to eliminate items or problems would be greatly appreciated

User avatar
Piledriver
Moderator
Posts: 21718
Joined: Sat Feb 16, 2002 3:01 am
Location: Van Alstyne, Texas

Re: Urabus...it's in the works (Subaru EJ20T build)

Post by Piledriver » Sun Jul 10, 2016 1:28 am

Next:Compression test, pull the plug and have a look at least. Maybe swap plugs.
A vacuum leak at the port or injector can also cause a dead hole at idle.
I, for one, regularly embrace our new robot overlords, as I am the guy fixing the robots...

User avatar
panel
Posts: 3606
Joined: Sun Sep 24, 2000 2:01 am
Location: Victoria B.C. Canada
Contact:

Re: Urabus...it's in the works (Subaru EJ20T build)

Post by panel » Tue Jul 12, 2016 11:52 pm

180psi on problem cylinder. Next I swapped the wiring from #1 to #3 and I can make this happen on the #3 cylinder now so it must be the wiring. I've triple checked it and absolutely no breaks in the two wires. I can see voltage there when it's running and when I put the LED MAC tools test light in there it strobes green and when you swap pins on the test light it lights up red so it must be working.

User avatar
panel
Posts: 3606
Joined: Sun Sep 24, 2000 2:01 am
Location: Victoria B.C. Canada
Contact:

Re: Urabus...it's in the works (Subaru EJ20T build)

Post by panel » Sun Jul 24, 2016 1:58 am

Just found this while surfing and looks to be really close to the same symptoms I've been chasing.
Legacy And Impreza Engines With
No Injection Pulse #1 Cylinder
Built into the fuel injection control
unit is logic that will shut off the #1
injector if the computer believes that it
can no longer control the Idle Air Control
Valve. Remember this design characteristic
if you are trying to diagnose a “hard”
code for the Idle Air Control Valve or a
dead miss in the number one cylinder
due to no injection at idle. A problem in
the Idle Air Control Valve circuit may be
responsible. (Component testing shows
that it most likely is not the valve itself.)
Also, if the computer is deprived of its
“back up power supply,” some computers
will generate a false code for the Idle
Air Control Valve and kill the injector for cylinder #1. The pin location of this
power supply can be found in the Control
Unit Module I/0 Signal pages of the
appropriate Service Manual.

User avatar
panel
Posts: 3606
Joined: Sun Sep 24, 2000 2:01 am
Location: Victoria B.C. Canada
Contact:

Re: Urabus...it's in the works (Subaru EJ20T build)

Post by panel » Wed Oct 19, 2016 11:42 pm

Decided to go Megasquirt late in the summer so lots of changes etc.

New intake done with hoses for the boost controller and the block (AOS.Air oil separator). No MAF (mass airflow sensor) on this grey pipe now.

Image

Took the crossover manifold off and took the old coolant sensor out , drilled and tapped her for a 3/8" NPT for the new GM style sensor.

Image

Ebay cheapy relays for fans(2),fuel pump and main relay.

Image

Block off plate for the idle air valve. I could run one but decided not to.

Image

And my 6yr old little helper blowing off the grinding dust after cutting off the spark plug lead holders, single coil pack mounts and ground bosses. I'm running CNP (coil near plug) now and the 4 coils are from a Chev LS2 engine.

Image

User avatar
billz60vw
Posts: 165
Joined: Fri Feb 12, 2010 3:46 am
Location: portland or

Re: Urabus...it's in the works (Subaru EJ20T build)

Post by billz60vw » Wed Oct 19, 2016 11:50 pm

panel,
looking good! looks like its almost ready to roll! you might want to check your email cause i sent you something..

User avatar
GS guy
Posts: 587
Joined: Wed Nov 06, 2002 3:01 am

Re: Urabus...it's in the works (Subaru EJ20T build)

Post by GS guy » Fri Oct 21, 2016 2:47 pm

Sweet Panel! Hopefully will simplify the ECU wiring and sensors. Lots of knowledgeable folks on here with setting up the MS. I also used the upper water manifold fitting for a coolant bleed/purge, but kept mine running through the TB back to the reservoir tank. Interested in seeing your CNP solution. Keep the updates coming!
Jeff

User avatar
panel
Posts: 3606
Joined: Sun Sep 24, 2000 2:01 am
Location: Victoria B.C. Canada
Contact:

Re: Urabus...it's in the works (Subaru EJ20T build)

Post by panel » Sat Oct 22, 2016 12:17 pm

GS guy wrote: Lots of knowledgeable folks on here with setting up the MS.
Thx , been running it since 2005 om my 2276T and then tried to go OEM 3 yrs ago when I went Subaru. I'm glad to be back :D

User avatar
Piledriver
Moderator
Posts: 21718
Joined: Sat Feb 16, 2002 3:01 am
Location: Van Alstyne, Texas

Re: Urabus...it's in the works (Subaru EJ20T build)

Post by Piledriver » Sun Oct 23, 2016 1:29 am

MS firmware and tuning tools have come a LONG way...
(MS1 kinda ran out of program space though, not much change there)
I, for one, regularly embrace our new robot overlords, as I am the guy fixing the robots...

User avatar
Corysvdub
Posts: 219
Joined: Fri Feb 03, 2012 11:05 pm
Location: San Pedro, CA

Re: Urabus...it's in the works (Subaru EJ20T build)

Post by Corysvdub » Sat Oct 29, 2016 11:22 pm

Awesome to see Panel! Im in the process of doing a subaru in my squareback as well, then after that maybe my bus.....
Type 3 Subaru powered EJ25

User avatar
Corysvdub
Posts: 219
Joined: Fri Feb 03, 2012 11:05 pm
Location: San Pedro, CA

Re: Urabus...it's in the works (Subaru EJ20T build)

Post by Corysvdub » Thu Mar 02, 2017 2:03 pm

Any more progress?...
Type 3 Subaru powered EJ25

User avatar
panel
Posts: 3606
Joined: Sun Sep 24, 2000 2:01 am
Location: Victoria B.C. Canada
Contact:

Re: Urabus...it's in the works (Subaru EJ20T build)

Post by panel » Wed Mar 08, 2017 12:05 am

Thanks for the interest. I've been away at school for 7 weeks and now back for 2 months but away again for 3rd yr after that. So I'm really trying to line up stuff. Also working on a single wheel utility trailer at the same time. But before that my harness guy at work who volunteered to make it has been away also for a couple of weeks. Hoping he comes over late this week to terminate the harness which is all in the bus and laid out. He's also doing some board mods for me from parts from the Dub Shop.

On the radiator side of things I'm almost done. Just finished off the brackets that will be mounted to the existing ones from my first attempt. Ignore the -12 JIC's, they will be cut off.

Image

User avatar
Corysvdub
Posts: 219
Joined: Fri Feb 03, 2012 11:05 pm
Location: San Pedro, CA

Re: Urabus...it's in the works (Subaru EJ20T build)

Post by Corysvdub » Wed Mar 22, 2017 12:36 pm

Cool, right on panel! I might do this on my bus, but mine is a double door panel​ so it has a belly pan. 😫
Type 3 Subaru powered EJ25

User avatar
Corysvdub
Posts: 219
Joined: Fri Feb 03, 2012 11:05 pm
Location: San Pedro, CA

Re: Urabus...it's in the works (Subaru EJ20T build)

Post by Corysvdub » Wed Mar 22, 2017 12:38 pm

Any progress is good progress
Type 3 Subaru powered EJ25

User avatar
panel
Posts: 3606
Joined: Sun Sep 24, 2000 2:01 am
Location: Victoria B.C. Canada
Contact:

Re: Urabus...it's in the works (Subaru EJ20T build)

Post by panel » Wed Mar 22, 2017 11:20 pm

I've seen 2 roof top rad conversions now. One was in an old school trunk.

Post Reply