Urabus...it's in the works (Subaru EJ20T build)

Are you one of those confused people who can't make up their mind?
Post Reply
User avatar
Corysvdub
Posts: 219
Joined: Fri Feb 03, 2012 11:05 pm
Location: San Pedro, CA

Re: Urabus...it's in the works (Subaru EJ20T build)

Post by Corysvdub » Sat Apr 29, 2017 3:33 am

Ya I've seen one on the rack too, he made it look like a Coleman stove.
Type 3 Subaru powered EJ25

User avatar
panel
Posts: 3628
Joined: Sun Sep 24, 2000 2:01 am
Location: Victoria B.C. Canada
Contact:

Re: Urabus...it's in the works (Subaru EJ20T build)

Post by panel » Sat Apr 29, 2017 7:38 pm

She ran today .......the RPM kinda gained more than I liked so I shut her down. No lap top connected. Don't think it's a vacuum problem so might be just the timing table that's loaded ?

I was able to repeat it half a dozen times.

User avatar
panel
Posts: 3628
Joined: Sun Sep 24, 2000 2:01 am
Location: Victoria B.C. Canada
Contact:

Re: Urabus...it's in the works (Subaru EJ20T build)

Post by panel » Mon May 01, 2017 10:52 pm

Found out why it started to accelerate (at idle) away from me. :oops: When I made the block off plate to by-pass the idle it just capped the outer hole. It still has the bypass hole connected from each side of the throttle plate internally , so basically a vacuum leak. I'm going to tap a 1/4" NPT into one of the holes....this should work better :)

Image

User avatar
itawolf
Posts: 294
Joined: Thu Sep 02, 2010 8:07 pm
Location: vestavia alabama

Re: Urabus...it's in the works (Subaru EJ20T build)

Post by itawolf » Sun May 28, 2017 8:47 pm

Updates Panel?
RET Marine 0317 --with VW on the lobe!!
Lots of iron in the fire

User avatar
panel
Posts: 3628
Joined: Sun Sep 24, 2000 2:01 am
Location: Victoria B.C. Canada
Contact:

Re: Urabus...it's in the works (Subaru EJ20T build)

Post by panel » Mon May 29, 2017 11:27 pm

Not much......rad is almost ready and fixed the above problem.Got my 1/8" silicone vacuum line installed and MS is properly mounted. Nothing left in the motor compartment to do so that's nice. Also ran the DB9 cable under the bus and into the area under the front seat. This will help clean up the cable stringing from under the rear westy bench/bed and over the bulkhead like I had it for a long time. Other than that pretty much all of my check-list is done. Bleed the coolant system of course but that's about it.

I'm at school now for my 3rd yr Millwright. In my 4th of 7 weeks. So when I'm home I'm hoping to have her on the road for the summer etc.

User avatar
itawolf
Posts: 294
Joined: Thu Sep 02, 2010 8:07 pm
Location: vestavia alabama

Re: Urabus...it's in the works (Subaru EJ20T build)

Post by itawolf » Tue May 30, 2017 1:06 pm

sounds good brother
saw ya post on youtube
ive talked to Jeff a few times good guy---boy that accent lol

jeff aka 2jeffs1
RET Marine 0317 --with VW on the lobe!!
Lots of iron in the fire

User avatar
panel
Posts: 3628
Joined: Sun Sep 24, 2000 2:01 am
Location: Victoria B.C. Canada
Contact:

Re: Urabus...it's in the works (Subaru EJ20T build)

Post by panel » Tue May 30, 2017 4:23 pm

I have seen some of his videos and yes he does have a strong accent. :lol:

User avatar
itawolf
Posts: 294
Joined: Thu Sep 02, 2010 8:07 pm
Location: vestavia alabama

Re: Urabus...it's in the works (Subaru EJ20T build)

Post by itawolf » Mon Jul 03, 2017 1:39 pm

any updates bro
at work and its slllllllooooooooooowwwwwwwww

so a stf catch up
RET Marine 0317 --with VW on the lobe!!
Lots of iron in the fire

Post Reply