Engine running badly

The VW Beetle. Everything about bugs!

Moderator: Marc

Post Reply
advinnie
Posts: 282
Joined: Mon Jun 10, 2013 6:54 am
Location: Oxfordshire

Engine running badly

Post by advinnie » Thu Jul 27, 2017 11:32 am

Hi all I've got a 1600 motor in my bug running a pair of dell carbs. Now she will run great for ever if I just drive her normally even if I take her to 4500 rpm she don't care BUT every time I'm silly with her and give it the beam in every gear like I have to accelerate hard she plays up. What is happening is that after I've been silly with her she will still accelerate nicely to about 2800 rpm then the engine engine seems low on power and doesn't sound smooth and is a little lumpy. This happens ever time IM silly in it but why?
She will tick over fine just starts to stumble at the 2800 rpm mark.
The fuel pressure is good at 3 psi there is no black smoke or popping from the carbs or exhaust, timing and valve clearance are good any more ideas?

User avatar
FJCamper
Moderator
Posts: 2670
Joined: Wed Nov 14, 2007 5:19 pm
Location: Birmingham AL

Re: Engine running badly

Post by FJCamper » Thu Jul 27, 2017 10:05 pm

Hi Advinnie,

Give us some specs, such as your Dell carb models, and your venturi and main jet sizes.

Thanks,

FJC

advinnie
Posts: 282
Joined: Mon Jun 10, 2013 6:54 am
Location: Oxfordshire

Re: Engine running badly

Post by advinnie » Fri Jul 28, 2017 2:11 am

Engine spec
1600 twin port
Stock internals except for a engle 100 cam
1.25:1 rockers
Pair of twin choke dell 36''s
Idle jets 58
Mains 126
Air correction 9164.3
Vents 32mm

User avatar
FJCamper
Moderator
Posts: 2670
Joined: Wed Nov 14, 2007 5:19 pm
Location: Birmingham AL

Re: Engine running badly

Post by FJCamper » Fri Jul 28, 2017 10:15 am

Hi Advinnie,

Try a set of 28mm venturis. Your 1600 might be able to run 32mm venturis if you had 9:1 compression, but your symptoms match a too-large venturi.

Rule of thumb is 28mm for 1600 engines in Dells, Webers, even Solex (Kadrons) if you have standard 7.x or even 8.x compression.

FJC

advinnie
Posts: 282
Joined: Mon Jun 10, 2013 6:54 am
Location: Oxfordshire

Re: Engine running badly

Post by advinnie » Fri Jul 28, 2017 1:11 pm

Cheers mate I'm now going shopping g for some 28 vents

Post Reply