Camber issues please help

The VW Beetle. Everything about bugs!

Moderator: Marc

Post Reply
UnlimitedEditions
Posts: 9
Joined: Sun May 14, 2017 11:24 am

Camber issues please help

Post by UnlimitedEditions » Tue May 23, 2017 10:07 am

Hi everyone,

Thought my splines were out as one side of my bug seemed lower on one side but with more native camber. (doesn't make sense)
The only thing i could think to do was to adjust the splines and see what happened.
after a couple of days of wrenching I raised that side but the camber issue remains,
the only thing i noticed, get this, someone had put two bushings under one body mount (on the right side) so i removed these bushings and put one back. (have no idea why someone would put two bushings there, the shock mount wasn't even accessible!)
this didn't affect things as far as camber goes.

Is there anything I can investigate?
was thinking about changing the shocks over next to see if that is the issue.
and lowering the right side again!! :shock: (getting through the carter pins)

This is become very time consuming.

I have some before and after pics of the Side I changed (right passenger side LHD car)

many thanks!!
You do not have the required permissions to view the files attached to this post.

UnlimitedEditions
Posts: 9
Joined: Sun May 14, 2017 11:24 am

Re: Camber issues please help

Post by UnlimitedEditions » Tue May 23, 2017 10:13 am

Before and after of the body mount... this was a suborn bolt to get out
Before bottom image after top image with the hitchhiker.
You do not have the required permissions to view the files attached to this post.

UnlimitedEditions
Posts: 9
Joined: Sun May 14, 2017 11:24 am

Re: Camber issues please help

Post by UnlimitedEditions » Wed May 24, 2017 7:28 am

looks like the front is lower on one side too... just comparing the gap from the wheel arch to the tire.
one wavy bug.

think i need some new torsion arms, better bite the bullet.

Post Reply